The black art of Wireless Networking

16 05 2010

It rained all day today so I was able to resolve a wireless issue I had experienced on a laptop a friend gave me to repair/rebuild.

After replacing a faulty hard drive and loading Vista from scratch I discovered the wireless would not link in to my wireless network.  Other computers in my home ran just fine on the wireless network so I ‘knew’ there was no problem with my network. In addition I could boot the laptop to Ubuntu 10.4 on a  Live CD and it worked just fine too. This ruled out the laptop hardware as well. The finger pointed at Vista and the Intel Drivers.

After a reload of the Intel drivers from both HP and Intel, and a reload of Vista from scratch again and still no joy. I was running out of options.

I did discover that if I set the IP address as fixed on the laptop it worked just fine, so it was connecting to the router just fine but not getting an IP address. Puzzling since I could get an IP address assigned automatically using Ubuntu using the same wireless adapter.

Out of options I rebooted a wireless access point even though all other computers and the same computer using Ubuntu worked just fine. That fixed the problem. Note the router I rebooted was NOT the one assigning IP addresses, just the access point the laptop was connecting to. Somehow the access point was preventing a specific combination of hardware/software from getting an IP address from another router. Weird.

Not sure what can cause a specific combination of Wireless router, Operating systems and Wireless divers to fail to get an IP address, but there you go. Wireless sometimes eludes any logic.

The old axim of  ‘reboot and try again’ lives on….

Equipment

  • Buffalo WHR-G54S Wireless access point (DHCP off) with DD-WRT
  • Buffalo WHR-G54S router (DHCP On) with DD-WRT
  • HP Pavillion DV2910US
  • Windows Vista Home Premium SP2 32-bit
  • Ubuntu 10.4 32-bit
  • Intel 4965AGN Wireless adapter
  • Marvell Yukon 88E8039 Nic